DYNALLOC

Read syntax diagramSkip visual syntax diagram
             .-N-.   
>>-DYNALLOC=-+-Y-+---------------------------------------------><

DYNALLOC
Specifies whether or not ZDT/IMS enforces usage of the database data sets specified in the dynamic allocation modules, when accessing databases in DLI mode.
N
The user is not forced to use the database data sets specified in the dynamic allocation modules when accessing databases in DLI mode.
Y
The user is forced to use the database data sets specified in the dynamic allocation modules when accessing databases in DLI mode.
If you specify DYNALLOC=Y:
  • The Database Data Set Display panel is displayed in the ZDT/IMS dialog when a DLI region type is selected on the Entry panel.
  • The JCL generated by ZDT/IMS dialogs does not include DD statements for the database data sets.
  • Batch functions running in DLI mode will fail if their JCL includes DD statements for the database data sets.
  • If, for an Edit or Browse in DLI mode, the database data set DD names are allocated to your TSO session prior to the DL/I batch processing region being started, ZDT/IMS frees the data sets allocated to these DD names.
  • The database data sets are dynamically allocated by IMS™.
If you specify DYNALLOC=N:
  • The Database Data Set Specification panel is displayed in the ZDT/IMS dialog when a DLI region type and a non-HALDB database is specified on the Entry panel.
  • The JCL generated by ZDT/IMS dialogs includes DD statements for non-HALDB database data sets.
  • In an Edit or Browse, ZDT/IMS allocates the database data sets specified on the Database Data Set Specification panel.

This parameter is optional. If it is not specified on the HFM1POPI macro statement, ZDT/IMS uses either the value specified on the HFM1POPD macro statement (if specified on that statement), or N (otherwise).

The user cannot override the value you specify for this parameter.

To ensure that the database data sets specified in the dynamic allocation modules are used when the subsystem is selected, you should also set URESLIB=N and URECON=N.